Fedora-29-下构建openwrt

#安装
dnf install git -y
dnf install -y gcc binutils bzip2 flex python perl make grep unzip gawk util-linux subversion -y
dnf install -y libstdc++ libstdc++-devel  gcc-c++ ncurses-devel openssl openssl-devel

#下拉
git clone https://github.com/openwrt/openwrt.git

cd openwrt

./scripts/feeds update -a

./scripts/feeds install -a

make menuconfig

make

#等待构建生成

#error
Prerequisite check failed. Use FORCE=1 to override.
gmake: *** [/root/openwrt/include/toplevel.mk:168: staging_dir/host/.prereq-build] Error 1
#需要安装
dnf install libstdc++ libstdc++-devel -y
dnf install gcc-c++ -y

make -r world: build failed. Please re-run make with -j1 V=s or V=sc for a higher verbosity level to see what's going on
make: *** [/root/openwrt/include/toplevel.mk:218: world] Error 1



<img src="https://ipsec.in/wp-content/uploads/2018/12/Screenshot_2018-12-16_03-55-38.png" alt="" width="1899" height="929" class="alignnone size-full wp-image-1098" />